Drupal 9.x

carousel d9

Inviato da vantonio7900 il 6 ottobre, 2020 - 14:05. Ritratto di vantonio7900

Buon pomeriggio,
ho aggiornato la versione di drupal da drupal 8.7 a drupal 9.0.6. Nella versione 8 per creare i carousel usavo il modulo owlcarousel, ma ho visto che per la versione 9 di drupal non è supportato!!!
Che mi modulo mi consigliate che sia adatto pure per il responsive, per sviluppare un carousel?
Grazie mille!

rimuovere classe da input form

Inviato da vantonio7900 il 5 ottobre, 2020 - 11:50. Ritratto di vantonio7900

Buongiorno,
devo rimuovere una classe da input text della form, ho aggiunto al file .theme del modulo la seguente
funzione, ma non sembra lavorare ...

function hook_form_alter(&$form, &$form_state, $form_id) {
  switch ($form_id) {
    case 'newslettersignup-form':
      $classes = &$form['inputs']['newsletteryouremail']['#attributes']['class'];
      $classes = array_filter($classes , function($e){

news letter

Inviato da vantonio7900 il 5 ottobre, 2020 - 09:52. Ritratto di vantonio7900

Buongiorno,
avrei necessità di aggiungere la news letter nel sito che sto realizzando con drupal core 9.0.6
Sapete se ha qualcosa di default per gestirla ? Mi sembra di capire di no...
Mi potete indicare in tal caso se ci sono moduli già fatti ?
Grazie mille

problema configurazione drupal

Inviato da vantonio7900 il 1 ottobre, 2020 - 10:58. Ritratto di vantonio7900

Buongiorno a tutti,
sto avendo questo problema con drupal 9 dopo aver fatto update.
Ho scaricato ed installato drupal 9 da riga di comando sotto xamp utilizzando drush, ed è andato tutto ok!
Solo che sto notando che quando faccio la chiamata alla main page ad esempio, la pagina me la vede correttamente, ma non si porta dietro alcuni file di css o svg.
Questo perchè quando carico la main page vedo che nella get ci sono delle chiamate di questo tipo

GEThttp://10.8.8.93/themes/bootstrap-italia/assets/sprite.svg

errore caricamento tab lato admin

Inviato da vantonio7900 il 25 settembre, 2020 - 13:25. Ritratto di vantonio7900

Buon pomeriggio,
ho dovuto fare installazione di drupal 9, e poi aggiunta del tema bootstrap-italia
il tutto seguendo questo link
https://git.drupalcode.org/project/bootstrap_italia/-/blob/8.x-0.x/READM...
Ho installato correttamente drupal 9 e caricato il tema con le sue librerie.
Però da quando ho caricato il tema, drupal non funziona correttamente, mentre prima di installazione
di tema era ok, funzionava. Un primo errore l'ho risolto installando un modulo beta per il tema di
bootstrap-italia per la precisione questo: