Errore strano di drupal
Salve, sono un principiante che vuole usare drupal.
Drupal mi da il seguente errore, al' inizio pensavo che per mancanza del database non si potesse installare ma adesso che ho il datebase mi fa sempre lo stesso errore.
Ecco il contenuto:
Requirements problem
The following errors must be resolved before you can continue the installation process:
The Drupal installer requires that you create a settings file as part of the installation process.
Copy the ./sites/default/default.settings.php file to ./sites/default/settings.php.
Change file permissions so that it is writable by the web server. If you are unsure how to grant file permissions, please consult the on-line handbook.
More details about installing Drupal are available in INSTALL.txt.
The directory sites/default/files does not exist. An automated attempt to create this directory failed, possibly due to a permissions problem. To proceed with the installation, either create the directory and modify its permissions manually, or ensure that the installer has the permissions to create it automatically. For more information, please see INSTALL.txt or the on-line handbook.
Che devo fare ?????

Risposte
Ciao Matteo, devi fare 2
Ciao Matteo,
devi fare 2 semplici cose:
1. vai in dir_drupal/sites/default, troverai il file "default.settings.php". Devi dare i permessi in maniera tale che questo file possa essere modificato e poi lo rinomini in "settings.php". Lo apri e lo configuri per le tue esigenze (per ex. la connessione al database). Gli assegni quindi i permessi per renderlo accessibile solo dal web server e proteggerlo dalle altre utenze.
2. Nella stessa directory (dir_drupal/sites/default) devi creare una cartella "files" accessibile a tutti.
CiauZ,
WaPoNe
grazie wapone,però il file
grazie wapone,però il file default settings è bello lungo non so cosa modificare e poi che significa dare i permessi, se mi aiuti su quest ultimo punto te ne sarei eternamente grato
Richiesta duplicata, vedi
Richiesta duplicata, vedi soluzioni:
http://drupal.it/node/6104 (default.settings.php)
http://drupal.it/node/6222 (permessi)